org.openqa.selenium.firefox.NotConnectedException: Unable to connect to host 127.0.0.1 on port 7055 after 45000 ms.

org.openqa.selenium.firefox.NotConnectedException: Unable to connect to host 127.0.0.1 on port 7055 after 45000 ms. Firefox console output:
*** LOG addons.manager: Application has been upgraded
*** LOG addons.xpi: startup
*** LOG addons.xpi: Skipping unavailable install location app-system-local
*** LOG addons.xpi: Skipping unavailable install location app-system-share
*** LOG addons.xpi: Ignoring file entry whose name is not a valid add-on ID:
.
.
.
*** LOG addons.xpi: startup
*** LOG addons.xpi: Skipping unavailable install location app-system-local
*** LOG addons.xpi: Skipping unavailable install location app-system-share
*** LOG addons.xpi: Ignoring file entry whose name is not a valid add-on ID: 

Most of you guys faced this issue while executing the selenium webdriver script on latest version of firefox browser. So What happens exactly is when you execute your selenium script on firefox, it just opens a blank page instead of opening the url of AUT(Application under test) on Firefox browser and throws org.openqa.selenium.firefox.NotConnectedException exception.

How to resolve this issue ?

1) Make sure the latest selenium version is configured into your project, if not, then download the latest version of it and configured the same with your project.

2) If you still face the same issue after downloading the latest selenium version then it means that selenium is not yet supporting the Firefox latest version installed in your system. In order to overcome from this situation, you need to downgrade the Firefox version and stop the automatic updates of Firefox browser until there is an update from selenium.

If you really like the information provided above, please don’t forget to like us on Facebook, you can also leave the comment.

Leave a Reply

Your email address will not be published. Required fields are marked *


Notice: Undefined offset: 0 in G:\PleskVhosts\automate-apps.com\httpdocs\wp-content\plugins\cardoza-facebook-like-box\cardoza_facebook_like_box.php on line 924